Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Сединение по OLE только в одну сторону

v7: Сединение по OLE только в одну сторону
Я
   lals
 
14.10.21 - 08:57
есть две базы БазаА и БазаБ
При попытке соединения с базойБ ошибка подключения к базе,
Из базыБ в БазуА подключается без проблем,
Система Вин 10 х64 При перетаскивании этих же баз на другой компютер с Вин 7 32
разрядную никаких проблемм нет.
   ChMikle
 
1 - 14.10.21 - 09:09
что за ошибку пишет ?
   lals
 
2 - 14.10.21 - 09:38
"Ошибка открытия исходной базы" но это в тексте модуля прописано
    Торговля=v7.Initialize(v7.RMTrade,"Enterprise /D """+Путь+""""+?(Моно=1," /M","")+?(ПустоеЗначение(Пользователь)=0," /N"+СокрЛП(Пользователь),"")+?(ПустоеЗначение(Пользователь)+ПустоеЗначение(Пароль)=0," /P"+СокрЛП(Пароль),""),"NO_SPLASH_SHOW");
    Если Торговля=0 Тогда Предупреждение("Ошибка открытия исходной базы."+РазделительСтрок+"Проверьте правильность настроек.");КонецЕсли;
то есть подключиться не уджлось
   Volodja
 
3 - 14.10.21 - 09:48
1. Неверный путь, пользователь или пароль к базе
2. База уже открыта (пытаемся к ней создать еще монопольный объект)
3. Если "путь" сетевой, то возможно нет разрешения на запись
4. Для пользователя назначен рабочий каталог, а самого каталога нет
   Kigo_Kigo
 
4 - 14.10.21 - 10:05
(3) + кириллица и пробелы в пути, тоже вызывает проблемы
   lals
 
5 - 14.10.21 - 10:08
(3) 1. Путь выбирается в вдиалоге и туда и сюда, паролей и юзеров нет, и то же самое с паролями и юзерами (изначально не было  для эксперимента поставил и юзера и пароль эффект = 0
2. Все компы вокруг выключены, ничего к базе не подключено, запускаю ее руками  в монопольном режиме все идет как надо
3 Путь не сетевой обе базы в общей папке D/1S
4.  ользователя нет пароля нет когда ставил с пользователем  то каталог для юзера не был определен
были советы что оболочка была скопирована,  снова поставил как бы сверху дистрибутив, 
 и по оболочке  ведь базаБ--->БазаАподключаютсяя на ура
и обе этих базы на другом компе  соединяются и туда и сюда
   lals
 
6 - 14.10.21 - 10:12
(4)  вот это как раз может быть но сейчас увы нету возможноости проверить, комп на удаленке вырубился
хотя както были проблемы на 64 битке имена реквизитов глючили которые были на кирилице,  выходил ихз положения тем что просто буква в букву переисывал реквизить уже под этой системой и  ошибка уходила
   lals
 
7 - 14.10.21 - 10:14
+(6) а папочка эта создавалась  под другой системой кажется еще на XP  и пока необходимости такой не было  оно и прокатывало
   Volodja
 
8 - 14.10.21 - 10:18
"Enterprise /D """+Путь+""""
После /D пробел (Хотя маловероятно, но в ЖК его нет.)
   Смотрящий
 
9 - 14.10.21 - 10:20
(8) Не должно быть пробела
   Volodja
 
10 - 14.10.21 - 10:21
(9) у него есть
   lals
 
11 - 14.10.21 - 10:27
(8,9,10) когда появится связь проверю  но как это объясняет то что одна и та же обработка  "оттуда сюда" подключается а "отсюда туда" нгет
   Volodja
 
12 - 14.10.21 - 10:35
(11) В списке информационных баз, обе базы зарегистрированы?
   Volodja
 
13 - 14.10.21 - 10:42
(11) и путь вы сейчас так передает:   /D"D:\bases\база2012" 
Попробуйте без кавычек
/DD:\bases\база2012
   lals
 
14 - 14.10.21 - 10:51
(12) обе зарегистрированы обе запускаются без всяких проблем по сети и локально
пути сейчас выглядят так
E:\1S\Зарплата
E:\1S\Зарплата2011
Из базы Зарплата2011 подключиться надо к базе зарплата  и это как раз не получается, а из базы Зарплата  запросто подключается  база  Зарплата2011
как только включат комп на той стороне проверю все предложеные варианты
   lals
 
15 - 14.10.21 - 17:19
соблюдая чистоту эксперимента  переношу обе базы с того компутера на свой с 10 вин 64 создаю  точно такую же  1S папочку  на диске Е
в модуле упрощаю до самоката

Процедура Открыть()
    v7=CreateObject("V77.Application");
    Оля = v7.Initialize(v7.RMTrade,"/DE:\1S\ZRP" ,"");
    Если Оля = 0 Тогда 
        Предупреждение("Ошибка открытия исходной базы."+РазделительСтрок+"Проверьте правильность настроек.");
    Иначе
        Сообщить("Подключено");
    КонецЕсли;
КонецПроцедуры 
 отркрываетт-закрывает базу как ни в чем не бывало
а на той  машине ни в дугу
   lals
 
16 - 14.10.21 - 17:24
база с кирилицей  в именги папки также прекрасно открываэтся на моей машине
    Оля = v7.Initialize(v7.RMTrade,"/DE:\1S\Зарплата" ,"");
   Базис
 
17 - 14.10.21 - 17:54
В реестре должны быть одинаковые записи "V77.Application", bin каталоги должны совпадать по именам EXE-шников.
   АгентБезопаснойНацио
 
18 - 14.10.21 - 18:34
(17) бин у него один.
   lals
 
19 - 14.10.21 - 18:46
(17) Вы имеете в виду на моей машине и на  проблемной?
Bin  каталоги стандартные C:\Program Files (x86)\1Cv77\BIN
сверил реестры все одинаково
Еще раз 
в системе ОДНА семерка
обе базы на одном диске Е:
в одном Каталоге /1S
одна база покдключается к другой а другая к ней нет
   Базис
 
20 - 14.10.21 - 18:48
Зайди под этим же пользователем интерактивно. Всякие советы при запуске, запросы открытия периода ОУ, отсутствующие каталоги пользователей на этом проверишь.
   lals
 
21 - 14.10.21 - 18:52
(20) Пользователей нет, паролей нет каталогов пользователей тоже нет вхожу что монопольно что  просто  никаких запросов и вопросов
   Базис
 
22 - 14.10.21 - 18:58
Юзера создай. Логи почитай. Процессы посмотри, может UAC какой их тогось.
   Volodja
 
23 - 14.10.21 - 19:19
(21) сделайте первый запуск 1С от имени Администратора, затем сразу обработку запустите
   lals
 
24 - 14.10.21 - 20:21
(22)  обнаружил в процессах переходит в фоновые и там торчит
(23) бляха с мухой  поехало
   lals
 
25 - 14.10.21 - 20:48
Всем спасибо решилось запуском 1С от Админа и затем все зашевелилось как надо


Список тем форума
 
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.