Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Добавить строки в чек ккт

v7: Добавить строки в чек ккт
Я
   Mafiozaa
 
18.09.20 - 07:27
Приветствую,есть ккт штрих м, на внешней обработке fr_elves.ert мне необходимо вывести на печать еще одну строку не могу сообразить как ее добавить, в драйвере она есть,а на самом чеке нет
   mishaPH
 
Модератор
1 - 18.09.20 - 08:32
(0) смотри комманду строка на печать драйвера
   mishaPH
 
Модератор
2 - 18.09.20 - 08:34
Функция глНапечататьСлипНАФР(ТекстСлипа,Экз=2,ОбрезкаСлипов=1,ПечатьЛоготипа=0,ПечатьТекстаРеламы=0) Экспорт
    Если глФРВкл = 0 Тогда
        Сообщить("Фискальный регистратор не подключен!");
        Возврат 0;
    КонецЕсли;
    
    Если ПустаяСтрока(глФРПарольПользователя) = 1 Тогда
        Сообщить("Неправильно указан пароль пользователя!");
        Возврат 0;                                         
    Иначе
        Попытка
            ПарольЧислом = Число(глФРПарольПользователя);
        Исключение 
            Сообщить("Неправильно указан пароль пользователя!");
            Возврат 0;                                         
        КонецПопытки;
    КонецЕсли;
    
    Если ПустоеЗначение(глФР) = 1 Тогда
        Сообщить("Устройство не подключено!");
        Возврат 0;
    КонецЕсли;
    
    Если глФР.УстройствоВключено = 0 Тогда
        глФР.УстройствоВключено = 1;
        Если глФР.Результат <> 0 Тогда
            Сообщить(глФР.ОписаниеРезультата);
            глФР.УстройствоВключено = 0;
            Возврат 0;
        КонецЕсли;
        глФР.GetStatus();
        Если глФР.Результат <> 0 Тогда
            Сообщить(глФР.ОписаниеРезультата);
            глФР.УстройствоВключено = 0;
            Возврат 0;
        КонецЕсли;
    КонецЕсли;
    
    глФР.Password = глФРПарольПользователя;
    глФР.Mode = 2;// режим отчетов без гашения

    глФР.SetMode();
    
    Если ПечатьЛоготипа <> 0 Тогда
        глФР.GetStatusPictureArray();
        Если глФР.PictureNumber > 0 Тогда
            глФР.PictureNumber = 1; 
            Если глФР.PictureState = 0 Тогда
                глФР.Alignment = 1;
                глФР.PrintPicture();
            КонецЕсли;
        КонецЕсли;         
    КонецЕсли;
    
    Если ПечатьТекстаРеламы <> 0 Тогда
        Если ПустоеЗначение(Константа.ТекстВЧеке) = 0 Тогда
            глФР.Caption = СокрЛП(Константа.ТекстВЧеке);
            глФР.Alignment = 0;
            глФР.TextWrap = 1;
            глФР.PrintString();         
            глФР.Caption = "------------------------------";
            глФР.PrintString();         
        КонецЕсли;        
    КонецЕсли;
    
    
    Для АА=1 По Экз Цикл
        КолСтрок = СтрКоличествоСтрок(ТекстСлипа);
        Для А=1 По КолСтрок Цикл
            Стр = СтрПолучитьСтроку(ТекстСлипа,А);
            
            Если СокрЛП(Стр)="" Тогда
                Стр = " ";
            КонецЕсли;
            
            глФР.Caption = Стр;
            глФР.Alignment = 0;
            глФР.TextWrap = 1;
            глФР.PrintString();        
        КонецЦикла;    
        
        Для Б=1 По 5 Цикл
            глФР.Caption = " ";
            глФР.PrintString();    
        КонецЦикла;
        
        //    Если глФР.Model = 35 Тогда

        
        Если ТекущаяИБЦентральная() = 0 Тогда
            Если Константа.НазваниеТекущейБазы.ОбрезкаСлипов <> 0 Тогда
                Если ОбрезкаСлипов = 1 Тогда
                    глФР.FullCut();
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        
        //    КонецЕсли;        

    КонецЦикла;
                                                         
    глФР.Mode     = 0;
    глФР.Password = "0";
    глФР.SetMode();                
    глФР.УстройствоВключено = 0;
    Если глФР.Результат <> 0 Тогда                            
        Сообщить(глФР.ОписаниеРезультата);
        Возврат 0;                          
    КонецЕсли;
    Возврат 1;    
КонецФункции// глНапечататьСлипНАФР




вот у меня функция для печати любого текста на ккм.
   victuan1
 
3 - 21.09.20 - 05:49
(2) "вот у меня функция для печати любого текста на ккм."
Не-а ;) Не любого - нет, например, управления размером шрифта, типа выравнивания.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.