Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Автогруппировка ТЧ и вывод значений группировки в строку

Автогруппировка ТЧ и вывод значений группировки в строку
Я
   Lorky
 
14.01.20 - 21:17
Хелп! Помогите тупому начинающему. Есть ТЧ с реквизитами Филиал и ФИО. Необходимо вывести на печать список ФИО с группировкой по филиалам, чтобы ФИО выводились в строку
Наприм.
Филиал1 = ФИО1, ФИО2, ФИО3...
Филиал2 = ФИО1, ФИО2, ФИО3...
Филиал2 = ФИО1, ФИО2, ФИО3...
и т.д.
Пока удалось реализовать только вот это, а дальше черт его знает что делать

    Макет = Документы.Группы.ПолучитьМакет("Филиалы");
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Таблица.Сотрудники.Наименование КАК ФИО,
        |    Таблица.Сотрудники.МестоРаботы.Наименование КАК Филиал
        |ИЗ
        |    Документ.Группы.Сотрудники КАК Таблица
        |ГДЕ
        |    Таблица.Ссылка В(&Ссылка)
        |
        |УПОРЯДОЧИТЬ ПО
        |    Филиал,
        |    ФИО
        |ИТОГИ ПО
        |    Филиал";


    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Результат = Запрос.Выполнить();
    ОбластьФилиалы = Макет.ПолучитьОбласть("Филиалы");


            ТабДок.НачатьАвтогруппировкуСтрок();
            
            Выборка = Результат.Выбрать();

            Пока Выборка.Следующий() Цикл
            ОбластьФилиалы.Параметры.Заполнить(Выборка);
            ТабДок.Вывести(ОбластьФилиалы,Выборка.Уровень());
    КонецЦикла;
    
    ТабДок.ЗакончитьАвтоГруппировкуСтрок();

КонецПроцедуры
 
 
   hhhh
 
1 - 14.01.20 - 21:32
(0) не, в автогруппировке такого нет, чтобы значения через запятую фигачило. Поэтому строку эту формируйте сами.
   Lorky
 
2 - 14.01.20 - 21:53
Т.е. от группировки вообще избавиться? Каким образом это можно реализовать?
   Lorky
 
3 - 14.01.20 - 22:02
(1) Новичку вообще реально разобраться?
   hhhh
 
4 - 14.01.20 - 22:49
(3) попробуйте сначала более простые задачки. Учебник Радченко почитайте. А к этому вопросу вернетесь потом, года через 3-4.
   Lorky
 
5 - 15.01.20 - 09:19
(4) Да я его и читаю, к сожалению нету столько времени, надо сейчас эту задачку решить
   hhhh
 
6 - 15.01.20 - 09:36
(5) ну типа так
        ВыборкаФилиалы = Результат.Выбрать();

            Пока ВыборкаФилиалы.Следующий() Цикл
        
                 Выборка = ВыборкаФилиалы.Выбрать();
                 СтрокаФИО = "";
                 Пока Выборка.Следующий() Цикл
                     СтрокаФИО = СтрокаФИО + Выборка.ФИО + ";";
                 КонецЦикла  
          
                 ОбластьФилиалы.Параметры.ФИО = СтрокаФИО;
                 ТабДок.Вывести(ОбластьФилиалы);

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.