Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

И вновь УПП: 126.2 -> 127.1

И вновь УПП: 126.2 -> 127.1
Я
   NorthWind
 
02.12.19 - 18:50
Добрый вечер!

Обновление 126.2 -> 127.1 валяет конфигуратор 8.3.11.2867 при окончательном сохранении базы на сервере (F7 в конфигураторе).
База при этом не ломается, но и не сохраняется, ее можно откатить к предыдущему релизу.
x32-x64 - не важно, поведение одинаковое. Под Win10 просто молча падает, под Win7 и Win2008 дает исключение в ucrtbase.dll.

Соответственно в связи с этим вопрос: кто что использует из следующих версий, что не имеет этой проблемы?
ЗЫ: живу на 8.3.11.2867 с июля, ранее проблем не наблюдал. Это первый случай.
 
 
   NorthWind
 
1 - 02.12.19 - 18:50
Да, чистка кэша также не помогает
   NorthWind
 
2 - 02.12.19 - 19:15
вообще кто-то обновлялся на 127 и 128, как оно?
   Фрэнки
 
3 - 02.12.19 - 19:26
А 128 это уже осенняя конфига? Может платформа нужна новая просто?
   Фрэнки
 
4 - 02.12.19 - 19:28
1С Сервер у тебя в какой разрядности? пишешь, что пофиг, но не так-то и пофиг - ключ, однако нужен соответствующей битностью
   shuhard
 
5 - 02.12.19 - 19:37
(0) платформа то какая ?
   NorthWind
 
6 - 02.12.19 - 19:54
(3) 128 это не просто осенняя, а ноябрьская конфига, только что вышла.
Затруднения возникли при обновлении на предыдущую, 127.1. То что нужна более новая платформа - я почти на 100% уверен. Вопрос - какую лучше поставить, чтобы не грела голову.

(4) x64.

(5) в (0) указано - 8.3.11.2867.
   NorthWind
 
7 - 02.12.19 - 20:05
x32-x64 - не важно --- имеется в виду клиентский конфигуратор. Естественно, первая мысль была - 32-битный упал по недостатку памяти. Нет. Расход памяти в момент падения невелик, около 350М, и падает одинаково что х32, что х64 конфигуратор. Дело в чем-то другом.
   Фрэнки
 
8 - 02.12.19 - 20:15
Ну если файл обновлений брал, то в нем же есть редми с указанием минимального релиза платформы и даже максимального. Наверное не выше какой-то 8.3.13, но не хуже 8.3.12
   NorthWind
 
9 - 02.12.19 - 20:20
(8) это все понятно. Интересует реальный "опыт жизни", какую платформу скачать чтоб не промахнуться
   Фрэнки
 
10 - 02.12.19 - 20:25
ну я к 8.3.12 особых претензий не испытывал, но мы из-за других "не моих" баз перепрыгнули на 8.3.14 - тоже нормально.
А вот 8.3.13 люди поругивают. Но мы через нее проскочили не задерживаясь.
   NorthWind
 
11 - 02.12.19 - 20:28
(10) во, это как раз то что интересно. Конкретные релизы посоветуете постабильнее из 12 ветки?
   NorthWind
 
12 - 02.12.19 - 21:16
Нет ответа... Ладно, пробую 8.3.12.1855, это последний из 12-й ветки, уже 19 года. И, по ходу, бинго - все сохраняется. Дело действительно в старом релизе. Ну что, ставить этот?
   Фрэнки
 
13 - 02.12.19 - 21:17
Я бы просто самый свежий взял. Потому что новую функциональность в пределах одного мажорного номера обычно не добавляют, а откровенные баги фиксят. :-)
   Фрэнки
 
14 - 02.12.19 - 21:18
Ну да. Ставь тогда его. Я на него тоже смотрел, но говорю же что спрыгнули на 14-ый из-за других баз, завязанных на дописывание своих самопальных моментов.
   NorthWind
 
15 - 02.12.19 - 21:19
это и есть самый свежий из 12 ветки... Вы говорите вообще про 8.3 или про конкретные ветки? Брать самый свежий из 8.3 это по-моему на любителя. Особенно в свете последних сегодняшних веток. У меня киосеры, правда, нет, но все равно :)
   Фрэнки
 
16 - 02.12.19 - 21:20
из 8.3.12 конечно
   NorthWind
 
17 - 02.12.19 - 21:22
(16) Спасибо!
   NorthWind
 
18 - 02.12.19 - 21:24
думаю, ветка пригодится тем, кто пользуется старыми релизами с УПП. Теперь есть очевидный повод обновиться.
   shuhard
 
19 - 02.12.19 - 22:26
(8) Текущий релиз конфигурации "Управление производственным
предприятием" предназначен  для  использования  с версией системы
1С:Предприятие 8 не ниже 8.3.12 


(18) проблема известна с лета, обновляй платформу
   NorthWind
 
20 - 02.12.19 - 22:30
(19) Тем не менее с июля все жило (и обновлялось) даже на 8.3.10. Необходимость безусловно перелазить на 8.3.12 возникла только со 127.1.
   AAA
 
21 - 03.12.19 - 06:56
Я обновлял нетиповую УПП и на 127.1 и на 128.1. Платформа 8.3.8.2068, стоит с весны, по моему она же и раньше была. База MS SQL, сохраняю в нем, выгрузкой пользуюсь редко. База около 50 гигов, поднять ее на  
sqlexpress невозможно. У меня проблем с обновлением не было, разве что с весны клиент переехал с 2008 винды и сервера на все 2012-ое и все стало медленнее раза в 2. У меня другой косяк - не всегда с первого раза удается сохранить конфигурацию в файл, выдается файловая ошибка и приходится доставать бубен. Но я бы не сказал, что безусловно надо переходить на 8.3.12. Это совсем неочевидно
   NorthWind
 
22 - 03.12.19 - 07:56
(21) ну вот у меня на 8.3.11.2867 падает обновление со 126.2 на 127.1. Падение происходит при обновлении БД, само обновление проходит корректно. Эффект устойчив, есть и на файловой и на клиент-серверной базах, на разных машинах, на x32 и x64 платформах. У меня не получилось добиться такого сочетания машины, платформы и файловой/клиент-серверной версии, при которой обновление бы прошло. База почти типовая с минимальными изменениями.
   NorthWind
 
23 - 03.12.19 - 07:57
тогда как на 8.3.12 конфигурация БД сразу же обновляется, причем довольно быстро.
   Фрэнки
 
24 - 03.12.19 - 08:59
(21) Если у тебя нетиповая УПП, то посмотри сам, откуда применяешь обновление? Т.е. на уровне встренного в CF файл бинарника (а он там точно есть) не происходит обращения к некоторым изменениям, которые в 8.3.12 есть, а в 8.3.8 их еще не существовало.

Кстати, поэтому и CF не всегда формируется - это следствие накопившихся структурных изменений/повреждений.

Можно еще порассуждать о нетривиальности получения типовых обновлений для давно установленных баз с большой историей изменений и т.п.
Но это уже будет откровенный оффтоп по отношению к заявленной в топике проблеме.
   AAA
 
25 - 03.12.19 - 18:45
(24)"Говорите помедленнее, я записываю" (Шурик)
a)Вы хотите сказать, что если мы возьмем какой нибудь старый релиз, типа 104.1 и будем обновлять его под 8.3.8 и 8.3.12, то в итоге получим разные типовые?
б)назовите для примера возможности, которые были  проигнорированы при обновлении под 8.3.8 и были бы установлены под 8.3.12
в)я всегда устанавливаю последовательно, по цепочке, через файлы обновлений
   Фрэнки
 
26 - 03.12.19 - 19:33
(25) начнем с того, что это все-таки мое частное мнение, для которого может не найтись прямых подтверждений у официоза.

Ну а на уровне лирики история началась с того, что

Я однажды попал на внедрение релиза УПП, которого не оказалось в списке официально опубликованных на релизах. Все бы ничего, но попытка применить к этому релизу официально существующие обновления не прокатывала. Сравнение потрохов CF получаемых сборкой из обновлений из официальных номеров и вот этого неофициального показало в нем наличие некоторых изменений на уровне бинарных встроенных кодов, которых в актуальных на то время типовых CF уже не было. Это была первая ласточка, которая заставила задуматься. А некоторые вещи из типовых CF так же отсутствовали в устаревшем, т.к. вероятно были добавлены позже или это была замена одних бинарников на другие.

Как выходили на том внедрении из необходимости получения типовых обновлений?
Очень просто - переносили ручками выявленные полученные обновления, периодически используя для анализа хранилище конфигураций, но не только к разработческой версии конфигурации, но и к типовой, что позволяло видеть почти все подробности прилетающего типового кода. За исключением бинарного. А в обновлениях, повторюсь, иногда прилетает и бинарный код.

В общем, ручное получение актуального релиза типовой не превращает его в абсолютную копию типовой :-)

Ну и кроме этого, я высказал подозрение, что построение из типовых обновлений новых версий типового ЦФ с использованием старых платформ имеет некоторую вероятность получения итоговых ЦФ не совпадающих ЦФ, который может быть взят непосредственно у разработчиков типовой.

Кстати, обратил какое-то время назад внимание, что после появления очень неприятных глюков, массовых глюков обновления, типовые обновления начали распространять с выкладыванием не только очередного CFU, но и просто целого дистрибутива с CF.

Особенно (специально выделяю абзацем), когда речь идет о необходимости замены релиза платформы почти всегда с релизом обновления выкладывают полный дистриб.
Но прямо в эти месяцы у меня лично нет доступа к скачиванию релизов УПП и я не могу это подтвердить пруфами.
   vis_tmp
 
27 - 03.12.19 - 20:31
(26)Что оимеешь в виду под "бинарный код" ?
   Фрэнки
 
28 - 03.12.19 - 20:33
(27) если ради этого исследования выгрузить конфигурацию в файлы, то быстро его найдешь в виде отдельных бинарных файликов.
   NorthWind
 
29 - 08.12.19 - 15:09
Ну-с, можно резюмировать следующее. В настоящий момент, а если точнее, то с релиза 1.3.127.1, предупреждение 1С по использованию платформы 8.3.12 для конфигурации УПП стало по-настоящему актуальным. Теперь действительно наблюдаются проблемы с обновлением релиза конфигурации на предыдущем 8.3.11. При использовании 8.3.12 проблемы полностью исчезают.
   vis_tmp
 
30 - 09.12.19 - 06:27
(29)Спасибо
 
 Рекламное место пустует
   vis_tmp
 
31 - 09.12.19 - 06:27
(28)А что в них?
   DrZombi
 
32 - 09.12.19 - 06:30
(12) Переходите на ЕРП, УПП снимается с поддержки :)
   Mikhail Volkov
 
33 - 09.12.19 - 07:02
(0) > База при этом не ломается, но и не сохраняется... Win2008 дает исключение в ucrtbase.dll.
Как это проявляется?
(29) Работаю на 8.3.10.2466, при обновлении на 1.3.127.1 проблем не заметил. Сейчас на 1.3.128.1, обновляюсь на 1.3.128.2...
   Aleksey
 
34 - 09.12.19 - 07:13
(22) у меня была "ошибка формата потока" когда я обновлял дома cf-ник на более свежем релизе платформы, а в офисе потом накатил полученный cf-ник. Причем ошибка проявлялась не сразу, а через некоторое время. После обновление платформы в офисе ошибка ушла. Естественно вендор не будет официально такую информацию распространять
   NorthWind
 
35 - 09.12.19 - 09:47
(33) тогда, возможно, косячный релиз именно 8.3.11.2867. Проявляется следующим образом: когда обновляешь базу данных после выполнения объединения (F7), спустя некоторое время должно появиться окно со списком измененных по отношению к текущей базе объектов конфигурации. До этого не доходит, вместо этого платформа либо молча падает (Win10), либо дает исключительную ситуацию в ucrtbase.dll.
   RomanYS
 
36 - 09.12.19 - 10:02
(32) Ужас! А когда?
   Mikhail Volkov
 
37 - 09.12.19 - 15:28
(35) > либо дает исключительную ситуацию в ucrtbase.dll.
Как это проявляется?
   Mikhail Volkov
 
38 - 10.12.19 - 09:05
Обновился на 1.3.128.2, ничего странного не заметил.
   NorthWind
 
39 - 10.12.19 - 09:18
(37) ну как-как. Программа выполнила недопустимую операцию, будет закрыта. Обычное окно ошибки Windows.
   NorthWind
 
40 - 10.12.19 - 09:20
впрочем, с 12 веткой я пока никаких особых странностей не вижу. Видимо, мы никогда не пользовались ломаными 1С, потому как все запустилось в штатном режиме и платформа ни разу нигде не наругалась про проблемы с целостностью :)
   CHerypga
 
41 - 10.12.19 - 09:56
чукча не читатель, чукча писатель, поэтому в ветке читал только первые сообщения. УПП 1.3.128.1, платформа 8.3.13.1644 (честное слово, это никак не связано с ограничениями лицензии КОРП). никаких проблем не замечено
как говорится: у меня точно такая же нога и ничего не болит
   NorthWind
 
42 - 10.12.19 - 10:04
(41) не такая же. У вас платформа 13. Речь идет про 11.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.