Вход | Регистрация
 

УТ 11.4.9.70 первичный ввод данных на остатки

УТ 11.4.9.70 первичный ввод данных на остатки
Я
   falselight
 
13.08.19 - 08:30
Подскажите пожалуйста как в УТ 11.4.9.70 правильно поставить номенклатуру на остатки?
С XLS приходят данные заказов. Нужно что бы они отражались на остатках.
Какие документы правильно для этого формировать?
 
 
   СтепаDS
 
1 - 13.08.19 - 08:58
(0) Отражались заказы?
   НадюшаЯ
 
2 - 13.08.19 - 08:59
Постановка просто супер)
   НадюшаЯ
 
3 - 13.08.19 - 08:59
Жаль не на китайском
   falselight
 
4 - 13.08.19 - 09:00
Как включить документы Поступление товаров на склад?
   АгентБезопаснойНацио
 
5 - 13.08.19 - 09:01
берешь номенклатуру, и ставишь на остатки. Если номенклатура тяжелая - закатываешь на остатки. или вызываешь грузчиков...
можешь взять остатки, и подсунуть под номенклатуру.
   falselight
 
6 - 13.08.19 - 09:01
(1) Товары. Сам пытаюсь понять как именно нужно.
   ДенисЧ
 
7 - 13.08.19 - 09:01
Заказы на остатках? Оррригинально...
   СтепаDS
 
8 - 13.08.19 - 09:01
(4) Куда включить?
   АгентБезопаснойНацио
 
9 - 13.08.19 - 09:02
(7) шел третий год после смены ника...
дурь оставалась в том же объеме...
   СтепаDS
 
10 - 13.08.19 - 09:02
(6) Что за бред несешь?
   piter3
 
11 - 13.08.19 - 09:02
ИТС есть?
   СтепаDS
 
12 - 13.08.19 - 09:03
(11) Вот, правильный вопрос)))
   falselight
 
13 - 13.08.19 - 09:07
(8) В администрировании, а то нет списка документов.
   falselight
 
14 - 13.08.19 - 09:20
Постановка такая.
Нужно грузить данные в эксель.
Что бы можно было видеть в УТ, что такого то товара стало на остатках больше на столько то.
У такого то товара цена изменилась на столько то.

Подскажите пожалуйста в какие документы для этого делать загрузку?
   piter3
 
15 - 13.08.19 - 09:21
Постановка полное г.
   falselight
 
16 - 13.08.19 - 09:27
Похоже сделать нужно это через ввод остатков.

(15) Предложите совою постановку? Как это может быть?

Постановщик, хочет что бы данные которые у него в эксель были в 1с!!!!!

Я считаю что это можно сделать вводом остатков.
   hhhh
 
17 - 13.08.19 - 09:32
(16) предлагаю номенклатуру никуда не переставлять. Пусть она стоит на прежнем месте.
   dezss
 
18 - 13.08.19 - 09:59
(16) Тут либо постановщик балбес, либо ты. Третьего не дано)))
Если он ведет весь учет в экселе, то нафига ему 1с?
   НадюшаЯ
 
19 - 13.08.19 - 10:04
(4) они теперь приобретение товаров и услуг
   ДенисЧ
 
20 - 13.08.19 - 10:05
(18) Почему либо? Это ж фальшлайт, тут сомнений нет...
   dezss
 
21 - 13.08.19 - 10:21
(20) Это да. Но мало ли, вдруг он стал умнее)
   СтепаDS
 
22 - 13.08.19 - 10:24
(21)  С чего бы вдруг))
   falselight
 
23 - 13.08.19 - 10:26
)))))))))))))))))))))))
Задача перевести данные с эксель в 1с.
)))))))))))))))))))))))))))))))))
планирую это сделать документов ввод начальных остатков.
   НадюшаЯ
 
24 - 13.08.19 - 10:27
так тебе надо добиваться одинаковости между 1с и эксель каждый день или разово перенести данные из эксель в 1с?
   falselight
 
25 - 13.08.19 - 10:30
)))))))))))))))))))))))))))))
Почему там указана цена в USD в демо документах ввод начальных остатков
как изменить на рубли? http://joxi.ru/Q2KbdNVCLJXW6m
   falselight
 
26 - 13.08.19 - 10:31
(24) Разово перенести из эксель в 1с.
   falselight
 
27 - 13.08.19 - 10:33
че, тут нет возможности редактировать сообщение, ни загрузки картинок в окно сообщения.
Не удаления отправленного нет?????????????????
   НадюшаЯ
 
28 - 13.08.19 - 10:36
(27) да
   НадюшаЯ
 
29 - 13.08.19 - 10:37
(25) валюты смотри регл и упр учета
   НадюшаЯ
 
30 - 13.08.19 - 10:37
(26) Переноси, да ввод остатков начальных
 
 Рекламное место пустует
   dezss
 
31 - 13.08.19 - 10:38
(26) Это должно было быть в (0)!
   НадюшаЯ
 
32 - 13.08.19 - 10:38
Дурная привычка сразу писать на форум
   hhhh
 
33 - 13.08.19 - 10:45
да тут без бутылки не разберешься. То пишет "данные с XLS". Потом вдруг "Нужно грузить данные в эксель". А теперь опять поменялось: "перенести из эксель в 1с"
   falselight
 
34 - 13.08.19 - 10:52
(33) с эксель в 1с.
   СтепаDS
 
35 - 13.08.19 - 11:31
(34) Точно?
   falselight
 
36 - 13.08.19 - 19:02
Я загрузил номенклатуру, и создал документ ВводОстатков на текущаю дату
как сейчас посмотреть что это есть на остатках? Каким отчетом?
Странно но на форме документа в режиме предприятия нет ни организации ни склада.

&НаСервере
Процедура ЗагрузитьНаСервере()
    МассивНайденных   = НайтиФайлы(КаталогДляФайлов, "*.xls"); 
    Для Каждого Файл из МассивНайденных Цикл 
        ТзСXLS = СоздатьТЗсXLSЛистов(Файл.ПолноеИмя);    
        //

        ДокументВНО               = Документы.ВводОстатков.СоздатьДокумент();
        ДокументВНО.Дата          = ТекущаяДата();
        ДокументВНО.ТипОперации   = Перечисления.ТипыОперацийВводаОстатков.ОстаткиСобственныхТоваров;
        ДокументВНО.Организация   = Организация;
        ДокументВНО.Склад         = Склад;
        ДокументВНО.Валюта        = Валюта;
        ДокументВНО.Подразделение = Подразделение;
        //

        Для каждого СтрТзXLS из ТзСXLS Цикл
            Если СтрТзXLS.Наименование = неопределено Тогда
                Продолжить;
            КонецЕсли;
            НоменклатураВДок                = ПолучитьНоменклатуру(СтрТзXLS);
            НоваяСтрока                     = ДокументВНО.Товары.Добавить();
            //НоваяСтрока.Артикул             = СтрТзXLS.Артикул;                                                             // 1.

            НоваяСтрока.Номенклатура        = НоменклатураВДок;                                                               // 2.

            НоваяСтрока.Количество          = ЧИСЛО(СтрТзXLS.Количество);                                                    // 3.

            НоваяСтрока.КоличествоУпаковок = ЧИСЛО(СтрТзXLS.Количество);                                                    // 3.

            //= СтрТзXLS.ОстаткиОбщий;                                                                                           // 4. 

            НоваяСтрока.Цена               = ЧИСЛО(СтрТзXLS.Стоимость);                                                      // 5.

            //НоваяСтрока.Валюта           = Справочники.Валюты.НайтиПоНаименованию(СтрТзXLS.Валюта,1);                    // 6.

            НоваяСтрока.Сумма              = ЧИСЛО(СтрТзXLS.Сумма);                                                            // 7.

            НоваяСтрока.Упаковка           = Справочники.УпаковкиЕдиницыИзмерения.НайтиПоНаименованию(СтрТзXLS.Единица,1);// 8.     

            //= СтрТзXLS.ВУпаковке;                                                                                              // 9.

            //= СтрТзXLS.АртикулПроизводителя;                                                                                 // 10. 

            //= СтрТзXLS.НомерПоКаталогу;                                                                                      // 11. 

            //= СтрТзXLS.Производитель;                                                                                        // 12. 

            //= СтрТзXLS.Дубликат;                                                                                             // 13. 

            НоваяСтрока.СтавкаНДС = Перечисления.СтавкиНДС.НДС18;
            //

            //Сообщить("");

        КонецЦикла;
    КонецЦикла;
    //

    ДокументВНО.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры
   falselight
 
37 - 13.08.19 - 19:04
(36+) Документ проведенный, но его отчет движения документа тоже ничего не показывает (((
Что нужно доделать?
Подскажите пожалуйста.
   Garykom
 
38 - 13.08.19 - 19:13
В УТ11 есть загрузка из екселя встроенная. Программировать не надо.
   Garykom
 
39 - 13.08.19 - 19:14
(37) Ты при создании кодом документа ВводОстатков накосячил и недозаполнил его правильно.
Сделай документ ручками и сравнивай выгрузкой в xml/json или еще как что заполнено правильно и чего у тебя не хватает.
   falselight
 
40 - 13.08.19 - 20:05
(39) Как то не совсем понятно.
Что я что то там недозаполнил, или заполнил не так как нужно согласен. Нужно доделывать, исправлять.

Буду разбираться. Благодарен подсказкам. Советам.


(38) А что это за загрузка?
   falselight
 
41 - 14.08.19 - 08:44
Здравствуйте!

(38) Так что это за волшебное средство, когда не надо программировать, и оно все само загружает???

(39) Ввел один документ. У него появились движения. Видимо мне так же нужно сделать.
Что это за метод .. выгрузкой в xml/json .. ? Как его использовать, чем?

Я пока что открыл этот документ в универсальном редакторе реквизитов v 2.4.1 и смотрю его заполнение.
   СтепаDS
 
42 - 14.08.19 - 09:58
(41) Продолжай наблюдения и обязательно докладывай.
   hhhh
 
43 - 14.08.19 - 10:13
(41) чет долго смотришь, уже 12 часов. И всё в одну точку? На книгу рекордов Гиннеса.
   falselight
 
44 - 14.08.19 - 10:25
Подскажите пожалуйста, вот так нормально?
Вроде движения появились. Как точно это проверить. Какими отчетами???


&НаСервере
Процедура ЗагрузитьНаСервере()
    МассивНайденных   = НайтиФайлы(КаталогДляФайлов, "*.xls"); 
    Для Каждого Файл из МассивНайденных Цикл 
        ТзСXLS                                   = СоздатьТЗсXLSЛистов(Файл.ПолноеИмя);    
        //

        ДокументВНО                             = Документы.ВводОстатков.СоздатьДокумент();
        ДокументВНО.Дата                        = ТекущаяДата();
        ДокументВНО.ОтражатьВОперативномУчете = Истина;
        ДокументВНО.ОтражатьСебестоимость     = Истина;
        ДокументВНО.ВидЦенностиНДС                   = Перечисления.ВидыЦенностей.Товары;
        ДокументВНО.ВидДеятельностиНДС             = Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС;
        ДокументВНО.ТипОперации                      = Перечисления.ТипыОперацийВводаОстатков.ОстаткиСобственныхТоваров;
        ДокументВНО.Организация                      = Организация;
        ДокументВНО.Склад                            = Склад;
        ДокументВНО.Валюта                           = Валюта;
        ДокументВНО.Подразделение                    = Подразделение;
        //

        Для каждого СтрТзXLS из ТзСXLS Цикл
            Если СтрТзXLS.Наименование = неопределено Тогда
                Продолжить;
            КонецЕсли;
            НоменклатураВДок                = ПолучитьНоменклатуру(СтрТзXLS);
            НоваяСтрока                     = ДокументВНО.Товары.Добавить();
            //НоваяСтрока.Артикул             = СтрТзXLS.Артикул;                                                             // 1.

            НоваяСтрока.Номенклатура        = НоменклатураВДок;                                                               // 2.

            НоваяСтрока.Количество          = ЧИСЛО(СтрТзXLS.Количество);                                                    // 3.

            НоваяСтрока.КоличествоУпаковок = ЧИСЛО(СтрТзXLS.Количество);                                                    // 

            //= СтрТзXLS.ОстаткиОбщий;                                                                                           // 4. 

            НоваяСтрока.Цена               = ЧИСЛО(СтрТзXLS.Стоимость);                                                      // 5.

            //НоваяСтрока.Валюта           = Справочники.Валюты.НайтиПоНаименованию(СтрТзXLS.Валюта,1);                    // 6.

            НоваяСтрока.Сумма              = ЧИСЛО(СтрТзXLS.Сумма);                                                            // 7.

            НоваяСтрока.СуммаБезНДС        = ЧИСЛО(СтрТзXLS.Сумма);                                                            // 

            НоваяСтрока.СуммаСНДС            = ЧИСЛО(СтрТзXLS.Сумма);                                                            //

            НоваяСтрока.СуммаРегл          = ЧИСЛО(СтрТзXLS.Сумма); 
            //

            НайденнаяЕдИзм = Справочники.УпаковкиЕдиницыИзмерения.НайтиПоНаименованию(СтрТзXLS.Единица, 1);
            Если Не НайденнаяЕдИзм = Справочники.УпаковкиЕдиницыИзмерения.ПустаяСсылка() Тогда
                НоваяСтрока.Упаковка = НайденнаяЕдИзм;                                                                    // 8.     

            Иначе
                НоваяЕдИзм              = Справочники.УпаковкиЕдиницыИзмерения.СоздатьЭлемент();
                НоваяЕдИзм.Наименование = СтрТзXLS.Единица;
                НоваяЕдИзм.Владелец     = НоменклатураВДок;
                НоваяЕдИзм.Записать();
                //

                НоваяСтрока.Упаковка = НоваяЕдИзм;                                                                        // 8.     

            КонецЕсли;
            //

            //= СтрТзXLS.ВУпаковке;                                                                                              // 9.

            //= СтрТзXLS.АртикулПроизводителя;                                                                                 // 10. 

            //= СтрТзXLS.НомерПоКаталогу;                                                                                      // 11. 

            //= СтрТзXLS.Производитель;                                                                                        // 12. 

            //= СтрТзXLS.Дубликат;                                                                                             // 13. 

            НоваяСтрока.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;
            // 

            НайденныйВЗ = Справочники.ВидыЗапасов.НайтиПоНаименованию("Собственный товар; Организация: ...мович ИП", 1 );
            Если Не НайденныйВЗ = Справочники.ВидыЗапасов.ПустаяСсылка() Тогда
                НоваяСтрока.ВидЗапасов = НайденныйВЗ;
            Иначе
                НовыйВД              = Справочники.ВидыЗапасов.СоздатьЭлемент();
                НовыйВД.Наименование = "Собственный товар; Организация: ...мович ИП";
                НовыйВД.Организация  = Справочники.Организации.НайтиПоНаименованию("...мович ИП", 1);
                НовыйВД.ТипЗапасов   = Перечисления.ТипыЗапасов.Товар;
                НовыйВД.Записать();
                //

                НоваяСтрока.ВидЗапасов = НовыйВД.Ссылка;
            КонецЕсли;
            //

            //Сообщить("");

        КонецЦикла;
    КонецЦикла;
    //

    ДокументВНО.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры
# КонецОбласти
   СтепаDS
 
45 - 14.08.19 - 11:42
(44) Что значит "вроде"?
   falselight
 
46 - 14.08.19 - 13:44
(45) Ну база чистая, первоначальная загрузка.
Много настроек, я и не уверен на 100% что все как нужно, по этому всегда, все, вроде.

Я и уточняю. Пытаюсь понять какими отчетами все проверить точно можно.
   hhhh
 
47 - 14.08.19 - 14:12
(46) надо вам какого-нибудь начальника завести. Или директора. Чтобы он вам выдавал волшебного пенделя под задницу в нужном направлении. Ведь сами прекрасно знаете, какие есть отчеты в УТ и как посмотреть движения документа, а всё равно задаете дебильный вопрос, чтобы потрепаться, потроллить форум.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.